Possible Problem at SNAP EBT
Incident Report for Payments Hub
Resolved
This incident has been resolved.
Posted Feb 17, 2021 - 18:38 EST
Monitoring
We have been made aware of an external upstream issue that may be impacting our merchants ability to process SNAP EBT transactions at their location.
Posted Feb 17, 2021 - 11:39 EST
This incident affected: Merchant Processing (EPX, Global (Partner), Fiserv (Partner)).