American Express Card Descriptors

Incident Report for Payments Hub

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 10:30 EDT

Investigating

We are currently investigating an issue that may cause some American Express card transactions to display incorrect merchant descriptor information on cardholder digital applications.

Our teams are actively working to identify the cause and assess the scope of impact. We will provide updates as additional information becomes available.

We apologize for any inconvenience and appreciate your patience.
Posted Jun 18, 2026 - 10:25 EDT
This incident affected: Merchant Processing (EPX).