Payments Hub - High Latency / Slow Loading
Incident Report for Payments Hub
Resolved
This issue has been resolved.
Posted Oct 08, 2023 - 13:23 EDT
Identified
Users of the Payments Hub are currently experiencing slower than usual load times for many web based features. The team is actively engaged and working toward a resolution.
Posted Oct 08, 2023 - 11:53 EDT
This incident affected: Payanywhere (Payments Hub - Merchant Portal).