Partner Hub - Batch Display
Incident Report for Payments Hub
Resolved
We have identified and resolved the issue as of 7:08 pm Eastern. All merchant batch data is now available in the Partner Hub. We appreciate your patience.
Posted Mar 05, 2024 - 19:15 EST
Investigating
We are currently investigating an issue involving the display of batches in the Partner Hub (partner.paymentshub.com). This does not impact the merchant view or processing.
Posted Mar 05, 2024 - 18:21 EST
This incident affected: NAB Services (Agent Portal & Reporting).