EPX - High Latency / Timeouts
Incident Report for Payments Hub
Resolved
The issue has been identified and stabilized. The team is continuing to closely monitor the platform. At this time all systems are fully operational.
Posted Jul 19, 2023 - 22:43 EDT
Investigating
We are investigating an issue that may be impacting merchants ability to run transactions. Merchants may be seeing timeouts or higher than expected latency.
Posted Jul 19, 2023 - 21:48 EDT
This incident affected: Merchant Processing (EPX).