NAB - Telecom Provider Issues
Incident Report for Payments Hub
Resolved
The issue has been resolved.
Posted Jul 05, 2023 - 14:12 EDT
Monitoring
We are currently experiencing an issue with our primary phone provider. At this time some callers may experience problems when attempting to reach us by phone. This issue is also impacting our ability to call out, resulting in longer than usual call back times.
Posted Jul 05, 2023 - 13:15 EDT
This incident affected: Shared Services (Customer Facing).