USAePay - Interruption
Incident Report for Payments Hub
Resolved
This incident has been resolved.
Posted Jun 14, 2023 - 23:05 EDT
Monitoring
We have been made aware of an issue with the 3rd party USAePay gateway. This may be impacting our merchants that are using the USAePay service for payments.
Posted Jun 14, 2023 - 19:59 EDT