Agent Hub - Merchants List Not Loading
Incident Report for Payments Hub
Resolved
This issue has been resolved, all features are working as expected. Agent Hub is fully operational.
Posted May 02, 2023 - 17:30 EDT
Monitoring
We are closely monitoring The Agent Hub after receiving intermittent reports from users who are experiencing problems loading the Merchants list after signing in.
Posted May 02, 2023 - 14:22 EDT
This incident affected: NAB Services (Agent Portal & Reporting).