Point & Pay - Service Interruptions
Incident Report for Payments Hub
Resolved
This issue has been resolved all system are fully operational and working as expected.
Posted Nov 17, 2023 - 13:39 EST
Identified
Point & Pay has re-opened access to the affected systems. Our teams are testing the environment for stability. Expect an update in 20 minutes
Posted Nov 17, 2023 - 13:12 EST
Investigating
Point & Pay has identified issues impacting our processing capability. To prevent customer issues, we have closed down access to the affected systems. Our team is working to resolve the situation as quickly as possible. Expect an update in 20 minutes
Posted Nov 17, 2023 - 12:59 EST
This incident affected: Point and Pay.