Payanywhere - Password Reset / Login Issue
Incident Report for Payments Hub
Resolved
This issue has been resolved and we will continue to monitor for delays with password resets that impact login. We are sorry for the disruption this has caused and thank you for your patience.
Posted Mar 05, 2024 - 17:57 EST
Update
We are continuing to investigate reports of delays with password resets with Payments Hub and Payanywhere that is impacting login. We appreciate your patience as we work to resolve this issue.


If your password is expired or was identified as a commonly used password, an alternate solution is to log in to paymentshub.com with your existing username and password. Do not click "Create or Reset Password". You will be prompted to reset your password (if it is expired or did not meet password requirements). Then you can log back in with your new password to both Payments Hub and the Payanywhere app.
Posted Mar 05, 2024 - 14:28 EST
Investigating
We are investigating reports of delays with password resets with Payments Hub and Payanywhere that is impacting login. We appreciate your patience as we work to resolve this issue.

An alternate solution is to reset your password directly on paymentshub.com. Log in with your existing username and password. You will be prompted to reset your password (if it is expired). Then you can log back in with your new password to both Payments Hub and the Payanywhere app.
Posted Mar 05, 2024 - 13:04 EST
This incident affected: Payanywhere (Payanywhere, Payments Hub - Merchant Portal).