AT&T Mobile Service Issues
Incident Report for Payments Hub
Resolved
The issue has been resolved.
Posted Feb 22, 2024 - 15:24 EST
Monitoring
We are following an ongoing issue with AT&T mobile cellular service. This may impact processing on mobile terminals using AT&T service.
Posted Feb 22, 2024 - 11:26 EST