VISA - Verification Failures
Incident Report for Payments Hub
Resolved
This issue has been resolved and all systems are working as expected.
Posted Nov 03, 2023 - 12:14 EDT
Update
We are continuing to monitor the issue with Visa Verification. Users are continuing to report error messages indicating that verification is unavailable. VISA is currently aware and are actively working on the problem. This issue is NOT impacting transactions processing at this time.
Posted Nov 02, 2023 - 12:57 EDT
Monitoring
We are monitoring an issue with Visa Verification. Users are reporting error messages that verification is unavailable. VISA is aware and they are currently investigating. This issue is NOT impacting transactions processing at this time.
Posted Nov 02, 2023 - 12:07 EDT
This incident affected: Merchant Processing (EPX).