Agent Hub - Merchants List Not Loading
Incident Report for Payments Hub
Resolved
This issue has been resolved, all features are working as expected. Agent Hub is fully operational.
Posted May 02, 2023 - 11:02 EDT
Investigating
We are currently investigating an issue within the Agent Hub. Users are able to sign in; however, the merchants list is slow to load or unavailable.
Posted May 02, 2023 - 10:46 EDT
This incident affected: NAB Services (Agent Portal & Reporting).