Inbound Phone Lines Unavailable
Incident Report for Payments Hub
Resolved
All phone lines are now accepting calls, all systems are back online. This issue is resolved.
Posted Nov 02, 2024 - 12:55 EDT
Monitoring
We are currently experiencing an issue with some of our inbound phone lines, including: 248-269-6000 and 800-226-2273, 866-485-8999

If you need to reach us by phone at this time please use this alternate number: 877-387-5640

Also note our Hospitality line: 248-298-8000 is also available.
Posted Nov 02, 2024 - 12:02 EDT
This incident affected: Shared Services (Customer Facing).