NAB - Merchant Enrollment Delays
Incident Report for Payments Hub
Resolved
This issue has been resolved.
Posted Apr 21, 2023 - 17:41 EDT
Monitoring
We are currently experiencing a delay in underwriting status updating in Partner Portal for new applications. Applications are being received and processed, status will be updated shortly.
Posted Apr 21, 2023 - 10:08 EDT
This incident affected: NAB Services (Merchant Enrollment).