Service Alert – Visa Funding Discrepancies

Incident Report for Payments Hub

Resolved

The issue impacting certain Visa transactions has been identified and corrected.

Affected Visa transactions that did not previously settle have now been successfully settled and are scheduled for funding. Due to the banking holiday, funding for impacted transactions is expected to be received on Monday.

We apologize for any inconvenience and appreciate your patience while we worked to resolve this matter.
Posted Jun 18, 2026 - 17:05 EDT

Investigating

We are currently investigating an issue impacting Visa transactions that are causing funding discrepancies for some merchants.

Our teams are actively working to identify the root cause and determine the scope of impact. We will provide updates as more information becomes available.

We apologize for any inconvenience and appreciate your patience while we work toward a resolution.
Posted Jun 18, 2026 - 12:30 EDT
This incident affected: North Services (Funding).