EPX - Emergency Maintenance
Incident Report for Payments Hub
Resolved
This issue has been resolved, all systems have been restored to normal operations.
Posted Jan 11, 2024 - 16:17 EST
Investigating
The team is preparing for emergency maintenance activities. We expect the activity to last less than 30 minutes, during the window merchant may experience issues processing transactions.
Posted Jan 11, 2024 - 15:51 EST
This incident affected: Merchant Processing (EPX).