Agent Hub - Merchants List Not Loading
Incident Report for Payments Hub
Resolved
This issue has been resolved.
Posted Sep 01, 2023 - 12:13 EDT
Investigating
We are investigating intermittent reports of users experiencing problems loading the Merchants list in the Agent Hub after signing in.
Posted Sep 01, 2023 - 11:52 EDT
This incident affected: NAB Services (Agent Portal & Reporting).