Partner Portal: Intermittent Page Load Errors

Incident Report for Payments Hub

Resolved

The issue was identified and resolved. Thank you for your patience.
Posted Aug 10, 2026 - 13:03 EDT

Investigating

Some users are currently experiencing issues logging in to the Partner Portal and receiving a "page not found" error upon login. The issue is intermittent and does NOT impact merchant processing. If you receive this message you can access the site and pages via the left side navigation.
Posted Aug 10, 2026 - 10:06 EDT
This incident affected: North Services (Agent Portal & Reporting).